Moto TC Rally

Device Compatibility

iOS

devices with Bluetooth LE:

Requirements for MOTO TC Rally App

iOS 6.0 or greater
iPad 3 and higher
iPhone 5s and higher
iPad mini and higher
iPod touch 5th gen and higher