Griffin Support

Do I need to update my iPod to use iTalk Pro?

Your iPod with video (5th generation) must be updated to at least Version 1.1.1. From the main iPod menu, go to Settings > About to see if your iPod has this update.

If you need to update it, go to http://www.apple.com/ipod/download/ to download iTunes.