Griffin Support

Is PowerMate compatible with Mavericks, Mac OS 10.9?

Yes, PowerMate is now compatible with Mavericks, Mac OS 10.9. Mavericks is compatible with PowerMate for Mac, version 3.0, which is available under the download section of the following page:

http://griffintechnology.com/support/powermate